HardwareSettings - Software freeze and inability to select controller.

Updated: 22 May 2024
Article #: 19


Behavior:

- Going to HardwareSettings will freeze the software.  User is unable to select the dropdown to find the controller.

 

Cause:

- User went to HardwareSettings' Camera tab with no camera connected.  User clicked Refresh, but since there was no camera, it wasn't able to get a camera's name.  User then clicked OK in this state.

 

Solution:

There's a particular file hidden on the PC that saves IP/Camera information for the Newton software.  Deleting/renaming it can force the software to freshly find all devices.  Please make sure the Newton software is closed before manipulating the files here.

- Find the AppData folder: In the taskbar search bar, search for "%AppData%".  This will find AppData/Roaming.

- Navigate up and around to AppData/Local/Temp/Newton.  The file you're looking for is here.

- Find the Configuration settings file (not the Configuration.mc file).  Attached picture shows what you're looking for.

- Delete this file.

- With that file out of the AppData location, relaunch the Newton software. You will need to go to HardwareSettings to find the controller.  This will create a fresh Configuration file.

 

This should stop that HardwareSettings window from freezing and allow you to reselect a controller again.







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